Stuck on Web-Interface Installation


#1

Hi everyone, I have a problem. I’ve finish server configuration but when I access web-interface it stuck blank page. Any suggest ? thanks

I found error at log
[php7:error] [pid 20830] [client 192.168.10.10:52731] PHP Fatal error: Uncaught Error: Class ‘Treo\Core\Application’ not found in /var/www/test/index.php:44\nStack trace:\n#0 {main}\n thrown in /var/www/test/index.php on line 44


#2

Hi virtualUser,

  1. According to the screenshot we can see, that the installation runs on windows. We recommend you to install the virtual machine with Linux/Unix und run the installation on it.
  2. According to the error we can say that the key class is missing, so it was not uploaded. This fact allows us to assume that the composer was not started.

#3

Hello, i’ve the identical problem on linux/docker

$php -v
PHP 7.2.15-1+0~20190209065123.16+stretch~1.gbp3ad8c0 (cli) (built: Feb  9 2019 06:51:24) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.15-1+0~20190209065123.16+stretch~1.gbp3ad8c0, Copyright (c) 1999-2018, by Zend Technologies

$apache-2.4.25

$mysql -v  
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 32
Server version: 10.1.37-MariaDB-0+deb9u1 Debian 9.6

$ps fax
  PID TTY      STAT   TIME COMMAND
    1 ?        Ss+    0:00 /bin/bash start.sh
   25 ?        Ss     0:00 /usr/sbin/sshd
  439 ?        Ss     0:00  \_ sshd: root@pts/0
  445 pts/0    Ss     0:00      \_ -bash
14149 pts/0    S      0:00          \_ bash ./bin/cron.sh 2048 /usr/bin/php
14154 pts/0    S      0:00          |   \_ bash ./bin/treo-composer.sh 2048 /usr/bin/php
18412 pts/0    S      0:00          |       \_ sleep 1
18413 pts/0    R+     0:00          \_ ps fax
  173 ?        S+     0:00 /bin/bash /usr/bin/mysqld_safe
  324 ?        Sl+    0:02  \_ /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/x86_64-linux-gnu/mariadb18/plugin --user=mysql --skip-log-error --pid-file=/var/run/mysqld/mysqld.pid
  325 ?        S+     0:00  \_ logger -t mysqld -p daemon error
13773 ?        Ss     0:00 /usr/sbin/apache2 -k start
13777 ?        S      0:00  \_ /usr/sbin/apache2 -k start
13779 ?        S      0:00  \_ /usr/sbin/apache2 -k start
13780 ?        S      0:01  \_ /usr/sbin/apache2 -k start
14019 ?        S      0:00  \_ /usr/sbin/apache2 -k start
14025 ?        S      0:01  \_ /usr/sbin/apache2 -k start
14026 ?        S      0:02  \_ /usr/sbin/apache2 -k start
14027 ?        S      0:01  \_ /usr/sbin/apache2 -k start
14204 ?        S      0:00  \_ /usr/sbin/apache2 -k start
14249 ?        S      0:00  \_ /usr/sbin/apache2 -k start
14320 ?        S      0:00  \_ /usr/sbin/apache2 -k start
18361 ?        S+     0:00 sleep 60


#4

Hi flipflip,
This problem may be caused, because you didn’t follow instructions correctly.


#5

maybe this will help you pals, i tried it in ubuntu 16.04. i dont try in docker

youtube ==> https://youtu.be/PZGomrMNrgM

step by step ==> http://bit.ly/2EvuR2T