Installing treopim via composer

Hi,
I’d like to install treopim with composer on osx 10.14. However running this command
composer require --no-update treolabs/pim:* && composer update
always leads to this error:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- php-mime-mail-parser/php-mime-mail-parser 2.10.0 requires ext-mailparse * -> the requested PHP extension mailparse is missing from your system.
- php-mime-mail-parser/php-mime-mail-parser 2.10.0 requires ext-mailparse * -> the requested PHP extension mailparse is missing from your system.
- Installation request for php-mime-mail-parser/php-mime-mail-parser 2.10.0 -> satisfiable by php-mime-mail-parser/php-mime-mail-parser[2.10.0].

Can anybody point me to the right direction how to solve this issue. I’ve have to mention, Iv’e installed mailparse extension successfully.
Kind Regards
Rolf

In the error it is written, that there is no extension “mailparse” in your system. Perhaps you have installed this extension not correct before. Please check if you really have this extension, use the command php -m | grep mailparse for it.

No this seems to be fine: Running this command in my terminal:

…$ php -i | grep mailparse
mailparse
mailparse support => enabled
mailparse.def_charset => us-ascii => us-asciimmand in the terminal

, gives me this result:

Any other idea.

please check for what PHP version you installed the extension and with what version the composer works

That was in fact the problem. My composer was linked to a different php version.
After fixing this, I was able to install treocore and pim. However after trying to install dam (php composer.phar require --no-update treolabs/dam:*) as well I’ve got a new error.

Problem 1
- treolabs/dam 1.1.2 requires treolabs/treocore ~3.19.0 -> satisfiable by treolabs/treocore[3.19.0, 3.19.1, 3.19.10, 3.19.11, 3.19.12, 3.19.13, 3.19.15, 3.19.16, 3.19.17, 3.19.2, 3.19.3, 3.19.4, 3.19.5, 3.19.6, 3.19.7, 3.19.8, 3.19.9] but these conflict with your requirements or minimum-stability.
- treolabs/dam 1.1.1 requires treolabs/treocore ~3.19.0 -> satisfiable by treolabs/treocore[3.19.0, 3.19.1, 3.19.10, 3.19.11, 3.19.12, 3.19.13, 3.19.15, 3.19.16, 3.19.17, 3.19.2, 3.19.3, 3.19.4, 3.19.5, 3.19.6, 3.19.7, 3.19.8, 3.19.9] but these conflict with your requirements or minimum-stability.
- treolabs/dam 1.0.2 requires treolabs/treocore ~3.18.0 -> satisfiable by treolabs/treocore[3.18.0, 3.18.1, 3.18.2, 3.18.3, 3.18.4] but these conflict with your requirements or minimum-stability.
- treolabs/dam 1.1.2 requires treolabs/treocore ~3.19.0 -> satisfiable by treolabs/treocore[3.19.0, 3.19.1, 3.19.10, 3.19.11, 3.19.12, 3.19.13, 3.19.15, 3.19.16, 3.19.17, 3.19.2, 3.19.3, 3.19.4, 3.19.5, 3.19.6, 3.19.7, 3.19.8, 3.19.9] but these conflict with your requirements or minimum-stability.
- treolabs/dam 1.1.1 requires treolabs/treocore ~3.19.0 -> satisfiable by treolabs/treocore[3.19.0, 3.19.1, 3.19.10, 3.19.11, 3.19.12, 3.19.13, 3.19.15, 3.19.16, 3.19.17, 3.19.2, 3.19.3, 3.19.4, 3.19.5, 3.19.6, 3.19.7, 3.19.8, 3.19.9] but these conflict with your requirements or minimum-stability.
- treolabs/dam 1.0.2 requires treolabs/treocore ~3.18.0 -> satisfiable by treolabs/treocore[3.18.0, 3.18.1, 3.18.2, 3.18.3, 3.18.4] but these conflict with your requirements or minimum-stability.
- Installation request for treolabs/dam * -> satisfiable by treolabs/dam[1.0.2, 1.1.1, 1.1.2].

Any idea how to fix that?

The thing is, that your Core version is 3.23, but at the moment, the module DAM supports the version 3.19