Installing Treocore PDOException

Hi,

i want to try TreoPim.
So my first step was to install TreoCore. I have installed it according to the GitHub guide but the website is only a blank page. There is only the TreoCore-Logo.

I got an error by starting the composer.
“composer create-project treolabs/skeleton test --no-dev” causes to this error:


The error occurs at the very end.

Thats what i can see when i access to the web interface (via ip/project_name):

I dont know how to solve the Problem. Can somebody help?

I get the exaxt same error in the same stage.
Using Linux mint 19.3 Cinnamon, PHP 7.2 and mysql 5.7.28

In addition, when opening the browser on http://127.0.0.1/my-treocore-project I get an error

Made some progress.
Reinstalled the Linux and then used https://www.linode.com/docs/websites/hosting-a-website-ubuntu-18-04/#web-server to install the LAMP stack.
Do not disable the *default host and you can skip the parts to create the example.com DB. Also, do not block anonymous access to the mysql DB.
Now I don’t get the mysql error and in the browser I get the same as shown above by ‘Made’.

Hey @udimargolin

I got a solution for my Problem. Maybe it helps you too.

I enabled the apache rewrite mode. The command is “sudo a2enmod rewrite”.

I hope this can help you too.

Hi. Thanks.
I tried it and it did not help.
Any other ideas?

Some more information:
I tried to install TreoPIM using the Composer GUI as proposed in the instructions.
I installed “composercat” and downloaded the TreoPIM package from Github.
I’m getting this error:


This indicates that there are missing packages that I found on Github but I don’t know how to install (as I have no Treocore UI, I cannot access the “MODULES” section

Any ideas?

Hello @Made, @udimargolin. Thanks for your feedback. This error was fixed in the latest release. Also make sure that the parameter “AllowOverride” is set to “All” in the server settings.

Hi,

I managed to get past the UI issue (did AllowOveride All and updated TreoCore to latest).
Now in the UI I get a screen to test DB connection. Tried a whole bunch of options but could not figure out how to pass this.
I have MySQL 5.7.28 and I’m able to create an “exampleDB” in the command line. The error I get is “invalid database settings” when trying the “Test Connection” or Next buttons.

Any idea?

Got past this one as well.
Created a ‘db’ database with a ‘db’ user and granted this user all privileges for the DB.
used standard (1306) port.

Now, my question is how to manage dependencies so I can get TreoPIM installed?

Looks like the TreoPIM instalation is done.
My cron configuration pointed to the wrong path.
Next step is to configure TreoPIM - stay tuned.